Important Notice


Important Notice

If you are getting credit card approvals through flowerSoft, you should have received this notice from Cayan.

Update on TLS Service Disruption 

As we previously informed you, the PCI Security Standards Council (SSC) has declared that the widely-used Transport Layer Security (TLS) 1.0 encryption method is no longer secure enough to keep sensitive information safe. Therefore, the PCI Security Council has mandated that TLS 1.0 must be disabled by June 30, 2018. Cayan has been working with its POS partners to ensure that they are ready for the upcoming deadline. Because it is not always clear to merchants if they are compliant with the new standard, Cayan will be implementing a series of short, scheduled brownouts in production. These brownouts are brief scheduled periods where Cayan will be disabling TLS 1.0 in all its products. Merchants whose Point of Sale does not support TLS 1.1/1.2 will be unable to process credit card transactions for the duration of the brownout. Merchants whose Point of Sale does support TLS 1.1/1.2 will be unaffected by these brownouts. Merchants affected by the brownouts are strongly encouraged to contact their POS provider to update their solution. We’ve intentionally left three weeks’ time between brownouts to give merchants time to bring their systems into compliance. Note that the brownout scheduled for April 2nd has now been canceled. Brownouts are now scheduled for the following periods:         • Monday, April 23: 10-10:15am EST         • Tuesday, May 15: 12-12:15pm EST         • Wednesday, June 6: 2-2:15pm EST         • Thursday, June 28: 4-4:15pm EST Cayan reserves the right to alter the above brownout schedule as necessary. July 1 Deadline If your POS doesn’t support TLS 1.1 or 1.2 before July 1, 2018, you will no longer be able to process card transactions. What is Cayan’s response? TLS 1.2 is already supported on Genius terminals, Virtual Terminals, Portals, and Payment Gateway. During its early-morning maintenance window on July 1, 2018, Cayan will disable support for TLS 1.0 in all its products, as mandated by the PCI Security Council. Since the deadline was announced in 2015, Cayan has been working with its POS partners and merchants to ensure that they are ready for the upcoming deadline. To help educate its merchants and draw attention to this deadline, Cayan is implementing the series of short, scheduled brownouts identified above. Why does this matter now? July 1 is 90 days away. The key to avoiding disruptions on July 1, 2018 is being prepared and updating to TLS 1.1 or 1.2 as soon as possible. How can I get started? Get in touch with your POS provider as soon as possible. Find out what version of TLS they’re currently supporting and ask them what their plan to update looks like. Don’t wait You can avoid brownouts and avoid the blackout coming on July 1st by acting now. Contact your POS provider or visit https://cayan.com/tls to discuss next steps today. Sincerely, The Cayan Team

If you are not sure if your flowerSoft has been updated to the latest version, which will support TLS 1.2, give us a call to schedule your update.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s